bash on windowsでのコンパイル環境作成

VisualStudioCode?でgdbデバッグする環境作成

bunnnycoindをVisual Studio Codeでデバッグする環境を作成する。

  1. VisualStudioCode?インストール(以後VSCodeと記述する)
  2. VSCodeでbunnycoinフォルダを開く
    1. VSCodeを起動して、メニューから「ファイル」>「フォルダーを開く」でbunnycoinフォルダを指定してフォルダを開く
    • 開くと、bunnycoinフォルダに ".vscode"フォルダが作成される。 bunnycoinを編集する際のVSCodeに関する設定がここに入る。
  3. C/C++拡張機能のインストール
    1. メニューから、「表示」>「拡張機能」を選択する。
    2. 拡張機能で c/c++ を検索して microsoft から提供されている c/c++ 拡張機能をインストールする。
  4. ターミナルのシェルをbashに変更
    1. メニューから「ファイル」>「基本設定」>「設定」を選択する。
    2. 画面右あたりの「ワークスペースの設定」をクリック。
    3. settings.json に以下2行追加して保存
          "terminal.integrated.shell.windows": "C:\\Windows\\sysnative\\bash.exe",
          "files.eol": "\n"
    4. メニューから「表示」>「統合ターミナル」を選択
    5. 表示されたターミナルがpowershellになっている場合は画面右下あたりターミナルの追加ボタン(+アイコン)をクリックする。
    6. bashを使用していいか聞かれるので"allow"を選択する。
    7. これで画面下にbashが表示される。
    • これで別ウインドウ開いてコンパイルとかしなくて良くなる。
  5. gdbデバッグ構成の追加
    1. メニューから、「デバッグ」>「構成を開く」を選択する。
    2. launch.jsonが表示されるので中身を以下のように変更
      {
        "version": "0.2.0",
        "configurations": [
          {
            "name": "(gdb) Bash on Windows Launch",
            "type": "cppdbg",
            "request": "launch",
            "program": "~/bunnycoin/src/bunnycoind", //ここ自分の環境に合わせる
            "args": [],
            "stopAtEntry": false,
            "cwd": "~/bunnycoin/src", //ここ自分の環境に合わせる
            "environment": "-datadir=/mnt/d/home/oquto/.bunnycoin/test1", //ここ自分の環境に合わせる
            "externalConsole": true,
            "pipeTransport": {
              "debuggerPath": "/usr/bin/gdb",
              "pipeProgram": "C:\\Windows\\sysnative\\bash.exe",
              "pipeArgs": ["-c"],
              "pipeCwd": ""
            },
            "sourceFileMap": {
              "/mnt/d": "d:\\"  // ここ、ubuntuのホームフォルダをおいているドライブになるように書き換え
            },
            "setupCommands": [
                {
                    "description": "Enable pretty-printing for gdb",
                    "text": "-enable-pretty-printing",
                    "ignoreFailures": true
                }
            ]
          }
        ]
      }
  6. デバッグ動作テスト
    1. 適当なソース(init.cppのAppInit?とかやりやすい)開いてブレークポイントを設定
    • 行数の左側クリックすると赤丸(ブレークポイント)が設定される
    1. メニューから「デバッグ」>「デバッグの開始」するとブレークポイントで実行が止まり、色々出来るようになる。

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2017-07-30 (日) 09:49:56 (866d)